Finalmente pude instalar Rails 3 en Leopard (OSX 10.5.5). Aparentemente era algo sencillo de hacer, pero el upgrade de Ruby y de RubyGems en Leopard no funciona del todo bien. Por lo tanto, luego de 12 horas, puedo decir que tengo Rails 3 funcionando, pero me hizo trabajar bastante.

Para que sirva de referencia, como bitácora o para que otro no transpire como lo hice yo hoy, lo dejo aquí registrado.

Antes de comenzar, la versión de OSX sobre la que lo hice es la 10.5.5 (Leopard):


El primer paso -antes de comenzar- es intalar MacPorts y esta versión específica de Xcode.

Inmediatamente después debemos eliminar del sistema (casi) todo Ruby y RubyGems:

sudo rm -r /System/Library/Frameworks/Ruby.framework/
sudo rm -r /Library/Ruby
sudo rm /usr/bin/ruby
sudo rm /usr/bin/gem

Luego instalamos RubyGems a través de MacPorts:
sudo port install rb-rubygems

Ya tienes RubyGems 1.3.5 en tu sistema, pero debemos actualizarlo a la versión 1.3.7. "sudo gem update --system" no hará el trabajao, por lo que debemos hacerlo de una manera alternativa:
sudo gem install rubygems-update
sudo update_rubygems

Terminados esos pasos, ya podemos proceder con la instalación de Rails3:
sudo gem install tzinfo builder memcache-client rack rack-test rack-mount erubis mail text-format thor bundler i18n
sudo gem install rails --pre

... y de esta manera, ya debería estar Rails 3 instalado en tu leopar 10.5.5:


Dime lo que piensas. Por favor, deja un comentario más adelante (y luego dale click a ese botón de 'Me gusta'!)

Seguir leyendo


Comentarios

comments powered by Disqus